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Arcon Evo - Quick Start
Arcon Evo lets you simultaneously plan and visualize your creative ideas in 3D. Unlike many CAD products, you
do not need specialist CAD knowledge to get the most from the software. Simply place your construction
elements, e.g., walls, doors, roof, stairs and windows, in the 2D project. With a single mouse click you’ll instantly
see these in a 3D environment. In this 3D environment you can also examine and control illumination effects, add
textures, materials and finishes and place and manipulate furniture objects.
Whether you’re an architect, self-builder, builder, interior designer or home improver, Arcon Evo not only provides high
performance planning software, but also an effective instrument for presentations. Often, substantial differences exist
between a project plan and an artist’s 3D impression, however, Arcon Evo' rendering and walkthrough in the building
project will help you avoid errors arising from such mistakes.
In Construction mode you work with the building project. To assist your construction, you have a ruler, guidelines and a
grid. High performance functions let you quickly place windows, doors and stairs easily, leaving you with full control and
maximum flexibility. The roof structure also works with a 3D preview and supports major types of roofing. With a mouse
click you can move into 3D Furnishing mode, which shows you the building in a 3D photo-realistic view. Here you can
plan the interior arrangement and environment. In addition, Arcon Evo includes a catalogue of objects and textures. By
simply using drag and drop you can place wallpaper on walls and furniture objects into living spaces. By placing lights,
you can include light and shadow in your plan. The integrated rendering module determines photo-realistic
representations of light, shadows, and reflections.

About this guide
While using Arcon Evo you will find many things in common with other Windows programs and where possible, Arcon Evo
makes use of standard Windows functions and dialog boxes. Accordingly, you will find familiar menu items such as File –
New, File – Open…, and Edit functions like Cut, Copy and Paste. Of course, the individual program functions and details
are different being adapted to the requirements of design and planning. If you have already worked with other Windows
programs, you will recognize the basic operation of the Windows user interface. For example, how to select a menu
option from a menu, how to open and minimise windows, and how to launch and exit a program. If these operations
sound unfamiliar, or if you are not comfortable with the Windows user interface, look at your Windows documentation.
If you have used previous versions of Arcon, the basic principles and operation will look familiar. However, the toolset,
options and menu interface will not be the same, so we would recommend taking time to familiarize yourself with this
version of Arcon Evo.
The purpose of this Quick Start guide is to help you familiarise yourself with software as quickly as possible. If you are
running Arcon Evo in trial mode, we do not expect you to be experts after your trial period has ended but we do hope that
you get on with our software and ask questions along the way if required! This guide will help get you started from placing
your first few walls to inserting windows and doors. If you require more detailed information on the tools, then we
recommend that you look at the Help system or reference manual found here:
https://www.3darchitect.co.uk/media/pdf/Arcon-Evo-Ref-Manual.pdf

If you have any specific questions, then please email us at 3darchitect@elecosoft.com

3

Arcon Evo journey from drawing your first wall to completing a finished set of
house plans!
When starting a house design project, one of the common questions is where to start and what are the different stages in
Arcon Evo to output a finished set of plans? The steps below will hopefully give you a better understanding of this
journey.
•
•
•

Start Arcon Evo
Setup new project (sheet size, project scale, etc)
In 2D Construction mode (below screen), start drawing out your external and internal walls

2D Construction mode
•
•
•

Next insert your windows and doors into walls
Insert other construction elements into your plan including stairs, supports, dimensions etc
Remember to keep viewing plan in 3D Design mode (below screen)
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3D Design mode
•
•
•
•
•

Next create new floor e.g. First Floor through the 'Floor' menu. You can transfer elements across from active floor
e.g., walls, windows, doors
Edit new floor (draw out walls, remove/ modify existing walls, add other construction elements)
Insert roof to top floor, modify it if required
Add other elements to roof e.g., dormers, skylights
Enter in to Plan Element mode (below screen)

Plan Element mode
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•
•
•
•
•
•
•

Create list of plan views (elevations, sections, floors)
Modify plan views using dedicated tools
Enter in to Plan Layout mode (below screen)
Setup sheet size
Select plan views from catalog (green icons) and drop them out on to sheet
Add other information to sheet including text, title block, logo, 2D objects etc
Send plan to print / create a PDF file

Plan Layout mode

For more advanced help on generating and editing elevations, section views and creating plan sets - click link below
https://www.3darchitect.co.uk/media/pdf/Plans_sets_elevation.pdf
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Mouse and keyboard control (pan, zoom, rotate, select)
There is a lot of interaction with your drawing and your 3D model, so it is important you understand the basic keyboard
and mouse controls before you start. We always recommend that you use a mouse as this gives you greater control
drawings out walls, rotating model etc compared to using a touchpad.

2D Construction mode controls
•

Pressed right mouse button
Shifts the floor plan view in the window when moving mouse

•

Move mouse wheel
Allows you to zoom in and out to selection

•

Left mouse button and selection tool
Use to select tools, menus and items in your drawing

•

Right mouse button pressed
Opens available context menu for item under cursor

3D Furnishing mode controls
•

Pressed right mouse button
Rotate and view 3D building from every side when moving mouse

•

Pressed right mouse button and Shift key
Shifts 3D building from side to side when moving mouse

•

Pressed right mouse button and CTRL key
Rotate 3D building around reference point when moving mouse

•

Move mouse wheel
Allows you to zoom in and out to selection
Left mouse button and selection tool
Use to select tools, menus and items in 3D.

•

Right mouse button pressed
Opens available context menu for item under cursor

•

Walkthrough mode
Pressed left mouse button and move mouse in direction to speed up walkthrough
Pressed left mouse button, SHIFT key and move mouse in direction to increase speed

Move
forwards

Move
backwards

Move
forward
left

Move
forward
right

Move
left

Move
right
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Turn left

Turn right

Starting a new project
1) Open Arcon Evo

2) On program start, the Project Assistant dialog will appear
3) From here you have different options but in this tutorial, select the option Start new blank project and click Finish

4) The following dialog will appear. From the drop down choose Ground floor
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5) Under the Height tab, you can adjust the storey height (you can adjust this at any point throughout your project). In
this example, keep it at 275 cm. We’ll go through how to change measurement units etc later.

6) The following screen will open in 2D Construction mode
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7) Locate the View menu at top of screen and select option of Layout View

8) The above will display the working sheet size and also incudes a drawing border. If you do not want to include the
drawing border then this can be hidden or removed via the Layer Manager (menu Layers > Layer Manager) . To
delete it from the worksheet please follow steps below
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Step1: Left click to select Drawing border layer
Step 2: Uncheck option ‘Lock element from further editing’
Step 3. Left click icon circled below to delete border

9) By accessing the menu Project > Project Properties, you can change sheet size, scale, unit of measurement etc at
any point throughout your project. You can update these at any point throughout project.
In this tutorial, change the sheet size to A4, unit of measurement to Metres and scale to 1:100. See below
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Drawing external walls using numeric input
There are several ways of drawing walls (look at reference manual/help system) but one of the easiest ways to
demonstrate this is using numeric input.

1) Firstly, in the vertical toolbar, locate and left click the Wall icon (circled above)
2) The Walls catalog will appear to right of screen (see above)
3) The small yellow sub folder means you can click and open this folder to display additional items. Left click the
Walls folder to display a list of construction types e.g., below. Refer to reference manual/help on how to edit wall
construction layers.
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4) Now left click on one of the walls e.g., Exterior wall (thick)
5) Next, select the Single wall input option

6) On your worksheet, left-click to set the start point of wall - e.g., below. Do not second left click at this point.

7) Move cursor out towards right and with your keyboard, enter 12. The Distance field in numeric bar at bottom of
screen will highlight - see below. You can check Angle in this tutorial check it is 0 deg. To change this, press the
TAB key on you keyboard. The Angle field will highlight. Here you can enter a different angle if required.
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8) Now press the Return button on your keyboard click the Apply button to set the end point of wall. Your first wall
is in place at 12 metres

9) Select same wall again, repeat above steps and snap cursor to corner point of wall below

10) Left click to define start point of second wall
11) Move cursor downwards. Use CTRL+W to toggle wall edges.
CTRL + W = Before placing walls in position, use the key combination Ctrl + W to toggle between the wall edges
and wall axis. This lets you define which wall edge you wish to place e.g., the inside edge of wall, centre line of
wall or outside edge of wall. Try pressing this key combination a few times to see the effect on screen.
Note: By also holding down the Shift key at same time of drawing wall will ensure that it snaps to a vertical or
horizontal position on sheet.

12) Next, using keyboard enter 6.6. As before the Distance field will highlight in numeric bar at bottom of screen.
Press the Return key or click the Apply button to set end point of second wall - see below
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13) Now try repeating above steps drawing out exterior walls using measurements below:

13. When the walls join, a room label will appear. This means that the walls are connected properly.
14. Press the F12 key or click the 3D Furnishing mode icon to display plan in 3D.

16

15) Press the F12 key or click the 2D Construction mode icon to return to your floor plan.

17

Add more walls
A series of guideline styles and types is available in the Tool Options catalog. The icons are the same as the 2D drawing
icons so in case you select the wrong tools, the word (Guideline) is used in label to help differentiate between the two.
You use guidelines in the same as you would use the 2D drawing tools except guidelines are just that. They are guides
used prior to drawing in construction elements to help you with accurate positioning quickly and easily. Unlike 2D drawing
elements such as lines and rectangles, guidelines will not appear on any printouts.
1) Select Guideline icon in left toolbar and click the option Parallel to reference line tool circled below

2) Next, left click the inside edge of wall below

3) In the dialog box that appears enter offset distance of e.g., 4 m
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4) A green guide will appear. Using mouse, you can move this either side of reference point (e.g., inside edge of wall
you selected above) at offset distance specified in dialog box above.

5)
6)
7)
8)

Next. left click to set guideline in position
Now do same and left click on inside edge of wall at top
Repeat steps above and this time enter 2.5 m in tool options dialog box. Left click to place guideline in position
You will have 2 guidelines in position shown below

Drawing single walls to guidelines
Using the guideline display above, this is one method to accurately measure out your plan before drawing out walls
and other construction elements. These can also be used for placing furnishing objects or marking out a building plot.
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1) Next, select an internal wall from Walls catalog and select the input method for Single wall.

2) Next, select an internal wall from Walls catalog

3) Now left click to set start point and draw the wall out along guideline. Use CTRL+W to toggle wall edges. See
below.

4) Draw wall out to where the vertical and horizontal guidelines meet and left click to set end point of wall.
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5) Repeat above steps and draw vertical wall as shown below. By following the steps above you will have created a
4m x 2.5m room.

Note: To learn more about walls please refer to the help system or reference manual where you will find a list of topics
covering different input methods.
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Inserting doors and windows
1) Left click the Window icon in left construction bar and select a window type from the catalog on right

2) Next, click the input method 'Window at set distance' followed by the Tool Options icon in top bar. In the Tool
Options dialog box that displays, enter an offset distance of 2 m

3) Close dialog box and left click in wall to set the reference point (where you want to offset window)
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4) Now left click again to position window in wall

5) Finally, move mouse to define opening and left click to complete window placement.

6) You place Doors in the same way as windows. Following above steps, insert additional windows and doors and try
using the input methods 'free positioning' and 'midway'

Note: To learn more about windows and doors please refer to the help system or reference manual where you will find a
list of topics covering these input methods.
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Note: You can turn off/edit display of Auto text e.g., window sill heights through menu 'Project > Automatic Labels'
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Adding stairs
1. Left-click the Stairs icon in left construction bar and select L-shaped stair from catalog on right

2. Define start point of stairs with a left-click
3. Move cursor or use numeric input field (same as you did with walls) to set length of stairs and left click
4. Move cursor or use numeric input field to define width and left click to set stairs in position

Note: To learn more about stairs please refer to the help system or reference manual.

25

Creating a new floor above or below current floor
1) Locate the Floors menu and select New Upper Floor

2) In the Copy walls tab, click on drop down list and select Only Exterior Walls. Also check the box for Windows,
doors, openings to copy

3) In the Floor tab select First floor in drop down
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4) Under the Height tab you can change properties e.g., Storey height. Keep settings below and click OK

5) Your new floor will be created and added to Floors drop down list (see below) where you can select which floor you
want Active e.g., for making changes to
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6) Under Floors menu you can choose which floors you want visible e.g. All floors Visible or Only Active Floor

7) Keep the option for All Floors Visible and enter 3D Furnishing mode (F12 key) or using the icon

8) You will see both the Ground and First floor together.
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9) If you selected the option to copy across doors and windows you can of course delete unwanted ones e.g., the one
selected above by left clicking on it (ensure the floor you want the item deleted from is the active one) and press the
Delete button on your keyboard. You can also delete items by right-clicking and selecting delete in context menu that
appears or select delete through the Edit menu.
Note: When you select items ensure you have clicked the Selection tool below. Pressing the Esc key will also take you to
this Selection tool.

10) You can now work on new floor in same way as previous floor e.g., drawing in walls, modifying walls, inserting
components such as windows and doors etc
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Documentation & Support
We hope that the above topics have given you some insight in to how some of the tool’s work in Arcon Evo and how floor
plans can be drawn out quickly and visualised in 3D.
If you do require further information on all the tools, then please refer to the help system in the software or the reference
manual below:
https://www.3darchitect.co.uk/media/pdf/Arcon-Evo-Ref-Manual.pdf
For more advanced help on generating and editing elevations, section views and creating plan sets - click link below
https://www.3darchitect.co.uk/media/pdf/Plans_sets_elevation.pdf
If you have any specific questions, then please email us at 3darchitect@elecosoft.com
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